Not compatibl with FF ver22 Rated 2 out of 5 stars

Not compatibl with FF ver22

Will be updated soon

Hi Anoop, thank you for your feedback. I'm currently working on finding a reliable API to make this add-on work across all regions. I'm definitely aware of this, and I will update it as soon as possible.