Rated 5 out of 5 stars

Support for firefox 6 and above ?

This review is for a previous version of the add-on (2.8.7.1-signed).