Make it work from Firefox > 3.7 Rated 5 out of 5 stars

In order to make the addon work in Firefox 3.7+ => Download the addon. Then open the XPI file using WinRAR/WinZIP/7zip and edit install.rdf. Make em:maxVersion="5" (For Firefox 5 just in case) and then put the updated file back into the XPI file. Then open the XPI file with Firefox and install it as you normally would.

This review is for a previous version of the add-on (0.0.8). 

Thanks for helping folks

I adjusted the compatibility to FF4 ages ago, but it was downgraded by the admin for undisclosed compatibility problems.
I've just bumped it back up because I couldn't find any problems with it, please let me know if this is working ok for you.