Rated 5 out of 5 stars

The 1.5 dev version is not compatible with Firefox 5

This review is for a previous version of the add-on (1.4).  This user has 2 previous reviews of this add-on.