Need an update Rated 2 out of 5 stars

Needs updated to be compatible with Firefox 8 and above. Thanks

This user has a previous review of this add-on.