Rated 5 out of 5 stars

Needs updating for FF 12 & above.

This user has a previous review of this add-on.