Rated 5 out of 5 stars

Needs updating for FF 12 & above.