"Firefox 30 hangs" fix found Rated 5 out of 5 stars

Problem in the Firefox profile, subdir \tidy which contains the file 'spvalid.err'. Normally this file is zero bytes, with no data. The file had been 'restored' from another PC running a different o/s. Removed subdir \tidy, then re-installated Add-in which has repaired the issues and HTML Validator is now running as anticipated. Thanks to Marc for hint about Firefox profile.

This user has a previous review of this add-on.

Don't appear on Add-on Bar Rated 4 out of 5 stars

I'ts a great tool. But, I have Firefox 29 and the icon don't appear on Add-on Bar.

Firefox 29

Thanks for the feedback. You are the fisrt person to complain about it. And seen Firefox 29 is new. I would like to solve your problem asap. I have Firefox 29 on my machine but no issue.

Please do this:
- Click on the new menu toolbar of Firefox 29.
- At the bottom, click customize. Do you see the HTML Validator icon there ?
If yes, drag and drop it on the toolbar where it was.

- if not, right click on an empty space in the toolbar and click "customize..."
- the same list should show.

Whatever is the result, good or bad. Can you send me the result to my email "mgueury@skynet.be" ?
- please add the OS and OS version
- the version from which you upgraded or after which change that
the problem happened.
- also if possible screenshot of the issue if it is still there.

Thanks,

Rated 5 out of 5 stars

My son likes this. Says he can do his job better with it.

Rated 4 out of 5 stars

As far as I know, it's the only add-on of its kind. Its automatic validation approach allows to detect that elusive unclosed tag that only shows up when you've loaded certain data (thus goes unnoticed with manual validation). Definitively, a must-have for webmasters.

The only major drawback is that it doesn't support HTML5 (it only provides a link to submit code to an online validator and such feature is provided by other extensions that do it better).

BTW, make sure you only use it on your own sites. There's no point in wasting memory and CPU cycles validating HTML at Google or Yahoo.

great but it hangs on different sites Rated 4 out of 5 stars

very often it hangs on different sites, so i close the FF with the Taskmanager. I cant say what site it is, one time it goes, other time it hangs

Make Firefox stop following clicked links... Rated 3 out of 5 stars

When I enable this addon, after several minutes Firefox stop to follow clicked links... I must close FF. However it still run in background and I must close it "really" via Task manager. No more problem when I remove the addon.

Hangs

Can you mail me ? mgueury@skynet.be. It would be interesting to know after which website visit that this is happening. There is a diagnostics logging to find this out. This is very probably related to Firefox bug https://bugzilla.mozilla.org/show_bug.cgi?id=839414

Thanks

Rated 5 out of 5 stars

Supppppppppppppperrrrrrrrrrbbbb<3

Excellent Rated 5 out of 5 stars

Fabulous tool. It's the biggest reason for my continued usage of Firefox.

This review is for a previous version of the add-on (0.9.5.1). 

ok when it works Rated 3 out of 5 stars

But it lags to computer bad after a while, and sometimes just goes into a jquery error loop making the computer unusable unless firefox is close and the computer is rebooted, This is on a vista with firefox 23.0.

This review is for a previous version of the add-on (0.9.5.1). 

Need more info

I am not sure of your issue. There are nearly no such issue reported since years about the extension. Except this firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=839414

The extension contains a work-around to try to avoid it.

Also note, you need version 0.957 for FF 23.

I would be pleased that you send me a mail explaining what you see, what you found. (mgueury@skynet.be)

Thanks

Rated 4 out of 5 stars

Firefox 23.0 update causes a problem. The application claims "not in domain list". This can be circumvented by invoking the page source, but that means an unnecessary extra step.

This review is for a previous version of the add-on (0.9.5.1). 

FF 23

Thanks for the problem report. It is a FF23 issue only.

A new version 0.957 will be available at home page http://users.skynet.be/mgueury/mozilla tonight (14 august 2013).

Then it will take some weeks to be approved and published in this site.

Very helpful Rated 5 out of 5 stars

Very helpful and easy to use. Good results and advices are retrieved.

This review is for a previous version of the add-on (0.9.5.1). 

Useful! Rated 5 out of 5 stars

Very handy to have in the view-source!

This review is for a previous version of the add-on (0.9.5.1). 

Rated 4 out of 5 stars

Very good extension/add-on, can't live without it.

However, I'm using Waterfox since I want to take advantage of the 64-Bit technology (speed, performance, etc.) since there's only 32-Bit Firefox (except the Nightlies), and HTML Validator doesn't work anymore.

Any idea when we could expect a 64-Bit-compatible version of this add-on?

Thanks.

This review is for a previous version of the add-on (0.9.5.1). 

could you please make it warp long lines then mark the line number Rated 5 out of 5 stars

Quite useful when validating the page per line and get errors corrected.
One suggestion, could you please make it warp long lines then mark the line number? I know it's hard to achieve, but it could much better to check for HTML on a responsive screen.

This review is for a previous version of the add-on (0.9.5.1). 

Problem Rated 5 out of 5 stars

Something wrong with extension. Use Firefox few years and auto update it to latest versions. This Validator always be in my set. At last time I can't update settings (can't press Ok in plugin setup menu) and see blank window in place where must be code inspection

This review is for a previous version of the add-on (0.9.5.1).  This user has a previous review of this add-on.

Russian Firefox ?

Are you using Firefox in Russian, I have 2 other users reporting this issue in Russian only. It seems to be linked to the "-1" of a preference who is not recognized as number only in FF 16-17 in russian. Don't ask me why :-) Mail me to mgueury@skynet.be for more info. Thanks

Ps: I got this from another russian user:
tidy.options.accessibility-check had STRING type in my about:config :
tidy.options.accessibility-check string -1

So I reset it and restarted firefox

After restart I have this
tidy.options.accessibility-check integer -1

It worked !

Must Have Rated 5 out of 5 stars

This is a must have add-on for web developers. Any chance it will be updated for FF 14 on OS X anytime soon?

Edit: I was able to update using the link below. The version displayed was FF 10.0x but I had no problem installing. Thanks!!!

This review is for a previous version of the add-on (0.9.5.1). 

OSX

The extension is compatible with FF14 on MacOSX.
Note that there is no version check in FF since FF11.

Download see here: http://users.skynet.be/mgueury/mozilla/download_090.html

Please send a mail to mgueury@skynet.be if it does not work.

Rated 5 out of 5 stars

essential add-on, use it practically every day

This review is for a previous version of the add-on (0.9.5.1). 

Rated 5 out of 5 stars

This is one of the most helpful extensions in my day to day work, along with Firebug. It's one of the things that brought me back to Firefox since it's available exclusively for it and it does such a good job.

For a long time I could not use it (on Linux 64bit) mostly because of Firefox breaking extensions on every release. I'm very glad it works again.

One feature I wished it had is an offline validator for HTML5, but maybe this will come too once the standard is closer to completion.

All in all, a great extension. Thank you Marc for taking the time to create and maintain this :)

This review is for a previous version of the add-on (0.9.5.1). 

Please add Windows 64 bit support Rated 5 out of 5 stars

With Waterfox there is now a well working 64 bit release of FireFox for windows and everything works very well, except this one extension. I like the extension and would be happy to be able to use it again.

This review is for a previous version of the add-on (0.9.5.1). 

Bravo! Rated 5 out of 5 stars

Thank you very much to have overcome the difficulties put before you by Firefox.

This review is for a previous version of the add-on (0.9.5.1).