Rated 1 out of 5 stars

There is a problem with this page showing older versions of the add-on. It shows ALL versions as only compatible for FF3.6 when in actual fact they are for older versions of FF. As a result it is not possible to download older versions :-(

This review is for a previous version of the add-on (2.2.0).