Rated 4 out of 5 stars

It was great - loved it. Then I upgraded to Firefox 3.5.7 and now to 3.6 and it isn't compatible. Do you plan to update this for the latest version of Firefox?

This review is for a previous version of the add-on (1.02).