Add-on Compatibility Reporter Version History

37 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 2.2.0 179.2 kB Works with Firefox 39.0a1 and later

Version 2.1.2 122.5 kB Works with Firefox 38.0a1 and later

Version 2.1.1 121.6 kB Works with Firefox 38.0a1 and later

Version 2.1.0 121.6 kB Works with Firefox 38.0a1 and later

Version 2.0.6.1-signed.1-signed 127.2 kB Works with Firefox 26.0 and later

  • Support Firefox versions with electrolysis enabled.

Version 2.0.5.1-signed.1-signed 120.0 kB Works with Firefox 26.0 and later

  • Fix syntax error which only appears in very recent Firefox versions.

Version 2.0.4.1-signed.1-signed 119.9 kB Works with Firefox 21.0 and later

  • Fix Firefox 32 compatibility issues.
  • Update widget code to use Australis UI module where available.

Version 2.0.3.1-signed.1-signed 119.8 kB Works with Firefox 21.0 and later

  • Fix timer issue.

Version 2.0.2.1-signed.1-signed 119.9 kB Works with Firefox 21.0 and later

  • Support for Firefox 29+.
  • Fixed leak in about:addons.

Version 2.0.1.1-signed.1-signed 312.3 kB Works with Firefox 19.0 and later

Version 2.0.1-signed.1-signed 293.6 kB Works with Firefox 16.0 and later

The Add-on Compatibility Reporter (ACR) has been redesigned and rewritten from the ground up to make it easier to use!

Version 1.1.1-signed.1-signed 158.0 kB Works with Firefox 3.5 and later, Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

- Fixing bug that caused Add-on Sync to break
- Added Danish (da) locale

Version 1.0.3.1-signed.1-signed 151.7 kB Works with Firefox 3.5 and later, Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Fix for bug 715493 : ACR 1.0.2 breaks AOM Add-ons Search in SeaMonkey

Version 1.0.2.1-signed.1-signed 154.0 kB Works with Firefox 3.5 and later, Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Fixes to make it fit better with 'Compatible by Default' builds of Firefox.
*NOTE* that add-ons marked to only work up to Firefox 3.6 or less will no longer be able to be enabled in 'Compatible by Default' builds of Firefox.

Version 1.0.1.1-signed.1-signed 182.5 kB Works with Firefox 3.5 and later, Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Fixes conflicts with new Default to Compatible features.

Version 1.0.1-signed.1-signed 144.0 kB Works with Firefox 3.5 and later, Mobile 4.0 - 11.0a1, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

- Mobile (Android) support!
- No 2nd restart needed after install to enable incompatible add-ons
- New locales (es-ES, fr, ru, and others)
- Better handling of misbehaving language packs
- New icon
For a full list of bug fixes, see http://bri.kz/cm

Version 0.9.3.1-signed.1-signed 108.4 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Aurora 10 compatibility support

Version 0.9.2.1-signed.1-signed 107.2 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Compatibility with the latest Thunderbird and Seamonkey nightly builds.

Version 0.9.1.1-signed.1-signed 149.2 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

- support to turn off prefs in latest Aurora builds 9.0a1 (bug 689853)
- improvements to compatibility button after you send a report (bug 671257)
- fix to add-on updates that are marked as compatible (bug 677567)

Version 0.9.1-signed.1-signed 138.7 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

* Incompatible add-ons will now be returned in Add-ons Manager searches
* Support for an upcoming addons.mozilla.org feature that will make it easier to install incompatible add-ons

Version 0.8.7.1-signed.1-signed 90.7 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Turning off feature where add-ons incompatible add-ons are immediately available post-install. A second restart is necessary again until we implement this feature correctly. For more details see bug 572322.

Version 0.8.5.1-signed.1-signed 125.2 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Thunderbird compatibility updates

Version 0.8.4.1-signed.1-signed 122.1 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 and later

Fixes support for Firefox 7.0a1

Version 0.8.3.1-signed.1-signed 122.0 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 and later, Thunderbird 3.0a1 - 3.3a3pre

Adds support for Firefox 6, 7, 8 and SeaMonkey 2.2.

Version 0.8.2.1-signed.1-signed 90.4 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.1b2, Thunderbird 3.0a1 - 3.3a3pre

Added 4.2 compatibility prefs for post-4.0 nightly builds of Firefox.

Version 0.8.1.1-signed.1-signed 89.3 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.1b2, Thunderbird 3.0a1 - 3.3a4pre

Minor update for compatibility with Firefox, post-4.0 beta period.

Version 0.8.1-signed.1-signed 41.2 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.1b2, Thunderbird 3.0a1 - 3.3a3pre

Updated to work with Thunderbird 3.3, plus maintenance fixes - http://bri.kz/acr08bugs.

Version 0.7.1-signed.1-signed 40.3 kB Works with Firefox 3.5 and later, SeaMonkey 2.0 - 2.1b2, Thunderbird 3.0a1 - 3.3a2pre

Added support for SeaMonkey, and maintenance bug fixes.
Full list of fixes: http://bri.kz/acr07bugs

Version 0.6 112.6 kB Works with Firefox 3.5 - 4.0b8pre, Thunderbird 3.0a1 - 3.3a1pre

* Preferences menu will no longer incorrectly be enabled for every add-on
* Enable and Disable buttons are no longer shown at the same time in Firefox 4's Add-ons Manager details view
* Fix button sizing issues in Firefox 4

Version 0.5.1 108.5 kB Works with Firefox 3.5 - 4.0b5pre, Thunderbird 3.0a1 - 3.2a1pre

Firefox 4 compatibility fixes (bug 576568)