Question Rated 5 out of 5 stars

The description says this works with Firefox 3.5 - 6.*.
However, the .RDF inside the .XPI has a MAXVERSION of 4.0
Is it safe to edit the .RDF and install this on 5.0?
I've rated this 5 stars so as not to change the excellent rating it has received.
Looks like a great idea.

This review is for a previous version of the add-on (1.0.4.1-signed.1-signed). 

Will be fixed

Thanks for this important input - we checked it out and have solved this issue.
We have resubmitted our add-on so it will soon support FF 3.5-6.
Regarding your question - yes, you can edit the RDF and install it on 5.0 (it is safe to use).

Thanks,
The woolik team