please update Rated 5 out of 5 stars

Hello,

If Mozilla ask why so many user don't update to FF4.
For me no update to FF4 before update notifier 1.5.6...

Please update.

Thank you.