Answer to Bumpy Rated 5 out of 5 stars

@ Bumpy,
You need Firefox 4 beta to have this little tab. See this page for more details: http://www.mozilla.com/en-US/firefox/beta/features/#feature-apps-tab

This review is for a previous version of the add-on (0.2).