WORKS for me on FF 54.0.1! Rated 5 out of 5 stars

At first, it showed that it was NO longer compatible! I downloaded the .xpi file and was then able to install it manually using that file without any problems!

Those saying it is incompatible are using Firefox 55+. Then it will not work without major changes.