OK, Here is how to get this to work with the New FF 5 + Rated 5 out of 5 stars

Ok, how to install the add-on on Firefox 4 upwards (FF will warn you that it is not compatable)
This should work on XP and Win7.
1.Go to your C drive and search for "thumbnailexpander@extensions.danwendorf.com"
2.When Windows finds that directory (should be in you appdata/local settings mine was C:\Users\{my username}\AppData\Roaming\Mozilla\Firefox\Profiles\6m5dkbrg.default\extensions\thumbnailexpander@extensions.danwendorf.com) open the folder.
3. open "install.rdf" with a text editor (notepad will do for you n00bs)
4.Look for : em:maxVersion="3.1a1pre"
5.change this to : em:maxVersion="7.1a1pre"
6.save the file, open FF, Thumbnail expander will now work.

Send me your thanks to em22uk@gmail.com

Chow!