Rated 3 out of 5 stars

I don't clearly understand :
Released April 21, 2012 AND works with Thunderbird 3.0 - 3.0.* ?
TB 3.0 was way back !

Will not install Rated 1 out of 5 stars

This add-on will not install in Thunderbird 12.