Rated 5 out of 5 stars

@dmbeast

Visit the Author site and download Tab Mix Plus 0.4.0.4pre.121214a.xpi (build release), its solved the problem with FF17.0.1.

This review is for a previous version of the add-on (0.4.0.3.1). 

Rated 5 out of 5 stars

Firefox 17.0 doesn't warn me when closing multiple tabs. The problem is Tab Mix Plus:

http://support.mozilla.org/en-US/questions/942381

This review is for a previous version of the add-on (0.4.0.3.1). 

Rated 5 out of 5 stars

Tab Mix Plus 0.3.8.6 is available if you click on " View all versions" (see the end of this page).

This review is for a previous version of the add-on (0.3.8.5). 

Rated 5 out of 5 stars

Everything works fine with TMP 3.8.3, FF 3.5.9, and WINXP. TMP is one of my favorites extensions. Thanks Onemen!

This review is for a previous version of the add-on (0.3.8.3).