Compatiblity Rated 4 out of 5 stars

It seems to be a wonderful add-on. But I use Thunderbird 3.1.7 and I couldn't install SyncOnArrival on it because of Version incompatibility. I really need such a tool to sync my mails on opening of TB. Please advise.