Update? Rated 2 out of 5 stars

I installed this on TB 3.1.5 by disabling add-on compatibility checking. Now that it's installed, I can't open its preferences (nothing happens when I click the button); other than that, I can't tell whether it's working.

It would be nice if this were updated. 1.5 was a long time ago and TB has changed under the hood.