Compatibility hack Rated 5 out of 5 stars

For those that are desperately seeking to override the version compatibility limitation, try installing MR Tech Toolkit (extension) first. It will then allow you to install this extension on an unsupported version. Works on 2.x. Have not tried it on 3.x.