No compatible with Thunderbird 3 Rated 1 out of 5 stars

No compatible with Thunderbird 3. I've also tried the Nightly edition but got the infamous "XXX will not be installed because it does not provide secure updates" message. After disabling security, I managed to install the XPI, the extension would not start, "options" kept crashing, etc.

This review is for a previous version of the add-on (1.0.4).