Let it works Rated 5 out of 5 stars

FIRST OF ALL: REALLY SORRY FOR MY BAD ENGLISH!

I think this extension is a great workaround for password multirequest bug and should be added to Thunderbird as native.
To let it work with thunderbird 9.0.1 (and later) do as follow:

1. Download the extension (.xpi file)
2. Rename startupmaster-1.3-fx+tb.xpi in startupmaster-1.3-fx+tb.zip (this is not mandatory, but helps)
3. Unzip startupmaster-1.3-fx+tb.zip or open it with any archive manager (like winzip)
4. Find the file install.rdf and open it with a simple text editor. This file is located in the root directory of the zip file.
5. Find the tag <em:maxVersion>. There are two occurrence of this: one in the <!-- Firefox -->
section and the other one in the <!-- Thunderbird --> section. The number next to this tag tells xpi installer wich is the max version this add-on works on. For example in the Firefox section you can see that the maximum version that this extension is compatible for is the 4.0b7.
6. Change the version numbers to the one you are interested in. For example in the Firefox section you can replace the string 4.0b7 with the string 9.1
7. add the modified file to the zip file or zip all the folder again and change file extension to .xpi
8. Install and use the extension

If you trust me you can download the modified xpi from here: http://www.zazy.it/temp/startupmaster-1.3-fx+tb-up.to.ver.9.3.xpi
I say sorry to developers for modifying their extension but it is over a month that it doesn't work anymore... if anyone is offended please just let me know.

WARNING: It's not guaranteed that this extension works with all future release of Thunderbird and firefox. I don't use it in Firefox and i'm actually successful using it with Thunderbird 9.0.1

This review is for a previous version of the add-on (1.3).