Update please. Rated 1 out of 5 stars

Needs to be updated to FF 4

This user has a previous review of this add-on.