v0.16 is required for Thunderbird 5 for me Rated 4 out of 5 stars

I've been using the Provider for Microsoft Exchange addon for some time and it's very good.
When I upgraded to Thunderbird 5 it didn't work for me with the newly updated v0.15 of the addon. Upgrading to v0.16 did the trick for me because it is now working again. Currently, v0.16 is marked as experimental and a manual upgrade is necessary, albeit a simple procedure.

This review is for a previous version of the add-on (0.15).