Rated 2 out of 5 stars

Doesn't work in FF 3.6 evgen after changing the Max. version.
Time to update, folks!

This review is for a previous version of the add-on (3.0.0.1).