Use Support Site link for newest version Rated 5 out of 5 stars

If you are not able to install this from Mozilla, try the Support Link to install latest version. It's at least compatible with FF 10.

http://yellow5.us/firefox/osb/

This user has a previous review of this add-on.