3.7 works Rated 5 out of 5 stars

OptinosMenu 1.8 works also with FF 3.7 - just change the Version in the install.rdf to 3.7.0 or 3.*