great extension but Rated 5 out of 5 stars

I really enjoyed working with this extension in TB1.5 but when I moved to the TB2 nightly builds, Tb doesn't state it as compatible (although I see it's compatible with 2.0b2. Can you please fix this,
I'm really thinking of goingback to 1.5 just for this extension,

thanks anyway,
Dror

This review is for a previous version of the add-on (0.2.2).