Noia 4 1.7.2 and 1.7.3pre3 Rated 5 out of 5 stars

I should have indicated that I am using Firefox UX 16.0a1 and that Noia 4, 1.7.2 and 1.7.3 pre3 show as Not being compatible, but I have 1.7.3 pre3 installed and working just fine!

Yes, there could be a problem with the Firefox Nightly updates, but they seem accurate on my end.

As mentioned, it's not a problem, just an observation! :)

This review is for a previous version of the add-on (1.7.2).  This user has other reviews of this add-on.

Before uploading I tested Noia on latest nightly and UX builds. The site just shows it wrong, it is compatible ;-)

I hope Mozilla fixes this soon.