How to install in TB2 Rated 4 out of 5 stars

There is a workaround to get this extension to install in TB2.

Try this...

Download the extension to your desktop. The file name is "newsworthy_for_thunderbird_1.5-0.2.0.4-tb.xpi".

Simply add ".zip" to the end of it. The result will be "newsworthy_for_thunderbird_1.5-0.2.0.4-tb.xpi.zip".

Use Winzip, WinRAR or whatever archiving software you use to open the newly created zip archive. Look for "install.rdf" and drag it out to the desktop.

Click on the start button, click on "Run...", type in "notepad" to open up the Notepad text editor. Drag "install.rdf" into the open Notepad window and you will see the contents of the file as text. Line 27, or about the 5th line from the bottom, should consist of something like "1.5.0.*". Edit that line to read something like "3.0.*". With that edit, you are telling the extension that it is OK to install in any TB version earlier than 3.1, which certainly covers any version of TB available as of this time. Save the edit and close the file.

Drag the freshly edited "install.rdf" back over to the archive window to overwrite the unedited version of the file still in the original archive.

Close your archiving program and remove the .zip extension you added, returning the extension file name back to its original state.

Open Thunderbird and install the extension as you would any other. If you did the job correctly, it WILL install! Restart Thunderbird as directed.

For access to the extension's settings, click on "options..." in the "Tools" menu. The "Newsworthy" icon should be the rightmost, or nearly the rightmost of the icons at the top of the menu box. As far as I can tell so far, the extension works properly, though I MAKE NO PROMISES! If I find a problem, I will get back to you.