Rated 5 out of 5 stars

Could you please make it compatible with Firefox 4 beta 2.

This review is for a previous version of the add-on (0.6.6). 

Firefox 4 compatibility

This is available in the sandbox, pending approval from the Mozilla Addons reviewers.