Frequent incompatibilities Rated 3 out of 5 stars

While the extension is nice, it is quite difficult to get the correct version for your Thunderbird and OS.

I recently accidentally upgraded from Thunderbird (well, Icedove) 17 to 24.4 and had to upgrade Lightning as well, but neither the current version nor the recommended 2.6.4 would run correctly. One even prevented Icedove from launching without safe mode.

Like I said, there's a history of this, so once you get it working, don't touch it!

This review is for a previous version of the add-on (2.6.4). 

One Lightning version per Thunderbird version

I don't know about Icedove, but could you specify (via a real support channel like the newsgroups or emailing me why its not working for you, what error messages you get? The stock Thunderbird 24.4.0 and Lightning 2.6.4 run without issues for me and I've heard a lot of others confirming this.

Indeed we unfortunately have strict version compatibility due to the binary component we are using. Each major Thunderbird version needs a specific Lightning version. See for more information.