Rated 1 out of 5 stars

The current version is incompatible with Thunderbird 24.0.1. Please help to update it to a compatible one.

This review is for a previous version of the add-on (2.6.4).