Update TB may fix compatibility issues. Rated 5 out of 5 stars

I like Lightening but it's not compatible with Thunderbird 17.0.5. With it being so essential to TB's usage I don't think Mozilla should release an update until it's compatible with all major addons, this being #1.

OK thanks for the reply. I assumed as I had the latest version that I was also using the latest TB, but apparently not, I'll do an upgrade when I get home.

This review is for a previous version of the add-on (2.6.3).  This user has a previous review of this add-on.

To use Lightning with Thunderbird 17 you need to use an older version, as linked on the main page. The latest version is compatible with Thunderbird 24, which is the new stable Thunderbird version.

I'd suggest to upgrade Thunderbird to 24 and then install the latest Lightning 2.6.3