Disapointed Rated 2 out of 5 stars

V1.9 was cool
V2.6 is totally broken on Linux (Fedora 15 here)

This review is for a previous version of the add-on (2.6). 

Known issue, specific to Linux only: https://blog.mozilla.org/calendar/2013/10/dont-upgrade-to-thunderbird-24-0-1-yet/