Installation of Lightning 2.6 fails Rated 5 out of 5 stars

When I try to install Lightning 2.6 i get the comment that it is not available for my platform. What is a platform? I am running
LinuxMint 13 KDE

This review is for a previous version of the add-on (2.6). 

Platform is like Operating System. Be sure to download the linux version of Lightning. For support please use the support link instead.