Not yet rated

Does not work with Ubuntu 7.10 and Thunderbird 2.0.0.12 (20080213). This is a real shame as I had become quite dependent on it.

This review is for a previous version of the add-on (0.8).