Key Manager Version History

28 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.1.240.20130821 7.3 MB Works with Firefox 24.0a1 - 24.*, SeaMonkey 2.21a1 - 2.21.*, Thunderbird 24.0a1 - 24.*

This version is compatibility update for Firefox 24/Thunderbird 24/SeaMonkey 2.21.

The CRL Manager component (for signing of Certificate Revocation List (CRLs) ) is removed because Mozilla PSM does not provide support for CRL any more.

Version 0.1.220.20130525 8.2 MB Works with Firefox 22.0a1 and later, SeaMonkey 2.19a1 and later, Thunderbird 22.0a1 and later

This version is compatibility update for Firefox 22/Thunderbird 22/SeaMonkey 2.19.

Version 0.1.200.20130314 8.0 MB Works with Firefox 20.0a1 and later, SeaMonkey 2.17a1 and later, Thunderbird 20.0a1 and later

This version is compatibility update for Firefox 20/Thunderbird 20/SeaMonkey 2.17.

Version 0.1.190.20130125 8.0 MB Works with Firefox 19.0a1 and later, SeaMonkey 2.16a1 and later, Thunderbird 19.0a1 and later

This version is compatibility update for Firefox 19/Thunderbird 19/SeaMonkey 2.16.

Version 0.1.170.20121207 7.9 MB Works with Firefox 17.0a1 and later, SeaMonkey 2.14a1 and later, Thunderbird 17.0a1 and later

This version is compatibility update for Firefox 17/Thunderbird 17/SeaMonkey 2.14.

Version 0.1.160.20120917 8.1 MB Works with Firefox 16.0a1 - 16.*, SeaMonkey 2.13a1 - 2.13.*, Thunderbird 16.0a1 - 17.*

This version is compatibility update for Firefox 16/Thunderbird 16/SeaMonkey 2.13.

Version 0.1.150.20120801 8.0 MB Works with Firefox 15.0a1 - 16.*, SeaMonkey 2.12a1 - 2.12.*, Thunderbird 15.0a1 - 15.*

This version is compatibility update for Firefox 15/Thunderbird 15/SeaMonkey 2.12.

Version 0.1.130.20120507 8.0 MB Works with Firefox 13.0a1 - 13.*, SeaMonkey 2.10a1 - 2.10.*, Thunderbird 13.0a1 - 13.*

Compatibility update for Firefox 13/Thunderbird 13/SeaMonkey 2.10.

Version 0.1.90.20120102 7.9 MB Works with Firefox 9.0a1 and later, SeaMonkey 2.6a1 and later, Thunderbird 9.0a1 and later

Compatibility update for Firefox 9/Thunderbird 9/SeaMonkey 2.6.

Version 0.1.70.20110928 7.6 MB Works with Firefox 7.0a1 and later, SeaMonkey 2.4a1 and later, Thunderbird 7.0a1 and later

Compatibility update for Firefox 7/Thunderbird 7/SeaMonkey 2.4.

Version 0.1.60.20110819 6.7 MB Works with Firefox 6.0a1 and later, SeaMonkey 2.3 and later, Thunderbird 6.0a1 and later

Compatibility update for Firefox 6/Thunderbird 6/SeaMonkey 2.3.

Version 0.1.50.20110810 5.3 MB Works with Firefox 5.0a2 and later, SeaMonkey 2.2 and later, Thunderbird 5.0b1 and later

Compatibility update for Firefox 5.0.

Version 0.1.50.20110729 5.3 MB Works with Firefox 5.0a2 - 5.*, SeaMonkey 2.2 - 2.2.*, Thunderbird 5.0b1 - 5.*

Firefox 5 compatibility update only.

Version 0.1.40.20110221 5.6 MB Works with Firefox 4.0b9pre - 4.0.*, SeaMonkey 2.1a1 - 2.1.*, Thunderbird 3.3a1pre - 3.3a4pre

This version is Firefox 4.0 compatibility update. No new feature is added.

Version 0.1.3.20090714 3.8 MB Works with Firefox 3.5 - 3.6.*, SeaMonkey 2.0 - 2.1a3, Thunderbird 3.0b1pre - 3.1.*

This is a compatibility update for Firefox 3.5.

Version 0.1.3.20090507 3.7 MB Works with Firefox 3.0 - 3.6a1pre, SeaMonkey 2.0a3pre - 2.0b1, Thunderbird 3.0b1pre - 3.0b3pre

This version (0.1.3.20090507) adds following capabilities:
- Added a new tab for certificate extensions specific to proxy certificate. This tab is only shown for proxy certificate signing
- Added the missing Javascript file to signing tool for update manifest (update.rdf) file. This tool uses the browser's certificate DB to chooses keys for signing and can be used as alternative to Mozilla's McCoy tool.
- Added a toolbar to the browser for launching various tools. To close the toolbar, use right-click and then deselect the 'Key Manager' check-box.
- modified the install.rdf to support Spicebird application.

Note: This version is only tested on Firefox3 for following x86 based OS: Linux, Windows XP/Vista, MacOSX.

Version 0.1.3.20090331 3.6 MB Works with Firefox 3.0 - 3.6a1pre, SeaMonkey 2.0a3pre - 2.0b1, Thunderbird 3.0b1pre - 3.0b3pre

This version (0.1.3.20090331) adds following capabilities:
- binding of following extensions to X.509 Certificate : Authority Information Access, CRL Distribution Points, Inhibit Any Policy, Policy Constraints (RFC3770)
- binding of MS-Crypto related key usages to Extended Key Usage certificate extension
- binding of Personal Identity Verification (PIV) Cards (http://csrc.nist.gov/groups/SNS/piv/index.html) related key usages to Extended Key Usage certificate extension
- SCEP-based certificate enrollment using RA
- allows password attribute in PKCS#10 CSR used in SCEP based certificate enrollment
- XUL based Wizard for signing and importing cert to external Java key stores; not supported on Windows OS - supported only on OS platform that has Unix-shell commands (bash, ksh etc.); use the preference (options) window of the add-on to enable it. It uses Java 'keytool' command to update Java key stores. You must set JAVA_HOME before starting the browser or use preference to specify it.

Note: This version is only tested on Firefox3 for following x86 based OS: Linux, Windows XP/Vista, MacOSX.

Version 0.1.3.20090109 3.3 MB Works with Firefox 3.0 - 3.6a1pre, SeaMonkey 2.0a3pre - 2.0a3, Thunderbird 3.0b1pre - 3.0b2pre

This version (0.1.3.20090109) adds following capabilities:
- ability to specify multiple values for attributes of subject-DN in Self-signed Cert/CSR generation form
- overlays a CRL signing tool buttons on top of browser's existing CRL Manager window. The CRL signing tool provides XUL GUI for what you can do using the 'crlutil' command-line tool of NSS. (Thanks to Scott Rea for suggesting and encouraging me to do this tool.)
- ability to export Key/certs compatible with OpenSSH-2 format
- ability to open OpenSSH connection in a terminal window. The OpenSSH client uses keys directly from the browser key/cert database without any conversion. Currently, it works on only those Linux distribution, like Fedora, that supports NSS patch for OpenSSH. You must make sure that OpenSSH client on your machine supports reading keys from NSS database.
- added a FIPS-compatible password status overlay for password change dialog window of Mozilla-PSM - use the preference (options) dialog window for this add-on to activate it
- modified the install.rdf to support Flock 2.* and Songbird 1.* applications.

This version is only tested on Firefox3 for following x86 based OS: Linux, Windows XP/Vista, MacOSX.
Note: For Ubuntu-8.04, this add-on works only with the FF3 downloaded from Mozilla site - this add-on will not work with Firefox3 that comes with Ubuntu distribution.

Version 0.1.3.20081007 2.6 MB Works with Firefox 3.0 - 3.1b3pre, SeaMonkey 2.0a2pre - 2.0a2, Thunderbird 3.0b1pre - 3.0b1pre

This version (0.1.3.20081007) adds following capabilities to the existing version :
- Ability to import/export OpenSSL compatible Keys/certs and Synchronize with application specific keys/certs (please read the usage document for details)
- Mount Keys/certs in PKCS#8 and PKCS#12 files as soft-tokens

Version 0.1.3.20080714 2.3 MB Works with Firefox 3.0 - 3.0.*

This versions adds following features to previous version of the add-on (v 0.1.3.20080615) for FF3:
- support for MacOSX-x86 and Linux-x86-64 for FF3.
- XUL based GUI to mount NSS based external certificate DB, created by other applications, as soft-token - use the preference (options) dialog window for add-on to activate it
- XUL based Wizard for certificate enrollment - use the preference (options) dialog window for add-on to activate it
- Fixes the bug in file extraction logic in XPI Signing tool (thanks Didier Stevens)
- Fixed ASN.1 encoding problem in Attribute Certificate

Version 0.1.3.20080615 2.0 MB Works with Firefox 3.0 - 3.0.*

This is minor upgrade to existing version. The XPCOM components are compiled with FF3-RC3 version for better compatibility.

This version works only on folowing x86 based OSes:
- Windows (Vista and XP),
- GNU/Linux (Fedora8, Fedora9, Ubuntu8.04, Suse).
It might work on other x86 based Linux builds but I have not tested them.

Although Mac OSX and Linux 64_x86 versions are included in the add-on XPI file but the add-on is not enabled for these two OSes. I couldn't successfully load the XPCOM libraries using the Firefox 3.

Version 0.1.3.20080528 1.6 MB Works with Firefox 3.0 - 3.0.*

This version is minor upgrade to the existing Firefox3 version.

There version adds following feature to current FF2 version 0.1.0.20080321:
- adds a form for Update manifest signing to the existing XPI signing tool
- implemented XBL template based button that can be embedded in the XUL elements for key generation and certificate enrollment.
- added the option to save PKCS#10 based CSR to a file in the "Export" cert dialog
This version is only tested on Firefox3 for following x86 based OS: Linux, Windows, Maco OSX.

THIS VERSION IS FOR FF3 ONLY.

For FF2/TB/SM1, please download the version 0.1.0.20080321.

Version 0.1.3.20080402 1.6 MB Works with Firefox 3.0 - 3.0.*

This version is compatibility update for Firefox3 on following x86 based OSes: Linux, Windows and MacOSX.
The C++ based XPCOM components are recompiled for updated NSS in Firefox3.
There version adds following feature to current FF2 version 0.1.0.20080321:
- adds a form for Update manifest signing to the existing XPI signing tool
This version is only tested on Firefox 3 - it may or may not work on other Mozilla Apps.

THIS VERSION IS FOR FF3 ONLY.

For FF2/TB/SM1, please download the version 0.1.0.20080321.

Version 0.1.0.20080321 1.6 MB Works with Firefox 1.5 - 2.0.0.*, SeaMonkey 1.1 - 1.1.*, Thunderbird 2.0.0.8 - 2.0.0.*

THIS VERSION IS FOR FF2/TB2/SM1.

This is the latest version for Firefox 2/Thunderbird 2/SeaMonkey1 on x86 based Linux/Windows/MacOSX.

This version adds following features:
- added support for x86 based MacOSX
- fixed a bug in key generation that was crashing Firefox in Vista

Version 0.1.0.20071203 1.2 MB Works with Firefox 1.5 - 2.0.0.*, SeaMonkey 1.1 - 1.1.*, Thunderbird 2.0.0.8 - 2.0.0.*

This version adds following capabilities to the previous version:
- Added two separate tabs for Proxy certificates in Certificate manager GUI : "Your Proxy" and "Proxy to You"
- support for using default certificate profile for key generation and certificate enrollment. This option allows one to set predefined certificate fields using either an XML file or copy from an existing certificate.
- Added Globus Grid Security based interfaces (Proxy (RFC3820) and Attribute (RFC3281) certificates) to the existing Mozilla NSS and PSM. Also, the tool provides XPCOM-based API for Attribute and Proxy certificates for scripting your own workflow.
- binding of following extensions to proxy certificate : Attribute certificate, VOMS SAML Assertions
- binding of following extensions to X.509 Certificate : WLAN SSID (RFC3770), Logotype (RFC3709) ,
- selection of EAP extended key usages (RFC3770)
- binding of following attributes to Attribute Certificate : Group, Role, Authentication Info, Access Identity, Charfing Identity, VOMS Group/Role, and WLAN SSID attributes (RFC3770)
- binding of following extensions to Attribute Certificate: Basic Constraints, No Revocation Available, Audit identity, Authority Key Id, Attribute Cert target
- customized existing OpenSSL key configuration tool for exporting keys and certificates for Globus security based applications
- XUL GUI for CSR generation and certificate signing has been reimplemented using XBL templates; you can now create yor own customize GUI or wizard based workflow for key/CSR generation just using the XUL tags.
- importing and exporting of temporary certificates while viewing in the certificate viewer. Saved certificate can be used for proxy based delegation as well as issuing attribute certificate.
- added support for installing on other non-Firefox Mozilla based applications: Thunderbird, SeaMonkey, Flock.

Version 0.0.2.20070320 736.3 kB Works with Firefox 1.5b1 - 2.0.0.*

Trying a work around the problem that download link is not being displayed for platform specific files.

Version 0.0.2.20070313 736.3 kB Works with Firefox 1.5b1 - 2.0.0.*

Fixed errors on DTD files. Fixed bugs in Archive signing tool and KeyManager.

Version 0.0.2.20070305 734.2 kB Works with Firefox 1.5b1 - 2.0.0.*

In this version, I added targetPlatform info in the install.rdf. This version only works on Linux and Windows.