FF 19 compatibility Rated 4 out of 5 stars

Need new update for FF19.

This review is for a previous version of the add-on (0.2.8.18). 

It's still pending review. The way i see it you have a few choices:
1. Install from https://addons.mozilla.org/en-US/firefox/addon/image-assistant/versions/
and/or
2. If urgent, feel free to email amo-editors@mozilla.org about this.

P.S. Using an ESR update would be another work-around option.