Rated 5 out of 5 stars

Please update to support Firefox 5.0

This review is for a previous version of the add-on (2.0.1.1-let-fixed).  This user has a previous review of this add-on.