won't install in Firefox ??? Rated 1 out of 5 stars

Tried to install and only got "Sorry, you need a Mozilla-based browser (such as Firefox) to install a search plugin". I AM running Firefox 19.0.2!