Latest TB version is 17.0.2 not 19.0 Rated 5 out of 5 stars

Update [2/11/2013]
My mistake. It's just that out of the box Thunderbird is great but Thunderbird Conversations is what makes it Outstanding!

Thanks for taking the time to clarify this =)

------------------
Why isn't the latest version of this add-on compatible with the latest version of Thunderbird?I'm running Thunderbird v17.0.2 [the latest stable version of TB] yet the latest version of Thunderbird Conversations is only compatible with Thunderbird v19.0 - 21.0 and above.

This review is for a previous version of the add-on (2.6.1). 

Because it's just a compatibility fix for the beta versions of Thunderbird, and it brings no new features compared to 2.5.2.