Compatibility with older versions should be changed. Rated 4 out of 5 stars

This is a complete re-edit of my reviews.
---------------------
Thanks to help from people on the Mozilla forums, with a little bit of fiddling in the install.rdf file, I was able to get this to install and work perfectly with Thunderbird 2.0.0.25pre and Firefox Namoroka. It worked perfectly "out of the box" with Aurora and the 64-bit Nightly.
-------------
P.S. In regard to the review from "chruschow", 2.0.2 worked perfectly on my 64-bit version of the Nightly using, of course, 64-bit Win 7. The update to 2.0.3 on that machine also worked perfectly. I'm not sure what the problem with chruschow's installation is.

Having said this, I might add that my profile for the Win7 machine was a re-worked copy of the one from my 32-bit Win XP machine, on which 2.0.2 was already functioning properly, i.e. I never actually tried to install 2.0.2 on 64-bit Win 7 or the FF 64-bit Nightly.
------------------------

P.P.S. I'm not sure what the poster who's had trouble with "mixed-up letters" is referring to. I've never noticed any problem of this type with this extension.

This review is for a previous version of the add-on (2.0.3). 

The dictionary itself in 2.0.3 is also updated compared to 2.0.2, to the most-current igerman98, as mentioned in the release notes.

(As a note, you really should update to Firefox 16 due to security issues with 3.6 - and there are ways to get almost exactly the same look-and-feel as with 3.6 even with newer versions, but the reviews of the German Dictionary add-on are not the right forum to discuss that.)

Grüße aus Österreich,
Robert Kaiser