Badly needs FF 4 Beta 10 Update Rated 4 out of 5 stars

Mime..and other users...
As always, this is a VERY good clearly solid add-on.

However we need to see even an "almost complete" Update that will work with Firefox 4 Beta 10 or greater soon ?

This review is for a previous version of the add-on (1.0.10).