Not compatible with Thunderbird 12.0.1.? Rated 1 out of 5 stars

Just wanted to install the latest version but it got this message: "Enigmail could not be installed because it is not compatible with Thunderbird 12.0.1." Do you have any plans to make Enigmail compatible? Many thanks!

This review is for a previous version of the add-on (1.5.2). 

Thunderbird 12 is not quite recent anymore and has known security bugs. I'd recommend you upgrade to the current stable version of Thunderbird - v17. Alternatively, you'll find a working version of Enigmail by clicking on "view other versions". You would need Enigmail v1.4.2 for Thunderbird 12.