Please i need it !! Rated 1 out of 5 stars

Anyone pls make it work with new TB 12.0 so thankfull !! HELLLLPPPPP ME PLEASE ..

I wish it was so easy... it needs third party software for which I do not have the source code, which means AMO would not review it.