Rated 5 out of 5 stars

Where's the 3.6 compatibility?? Comon!!!!!