Works perfectly with all but very old add-ons Rated 4 out of 5 stars

This add-on works precisely as advertized. Has allowed me to use several add-ons which this website claims are incompatible with FF v22, and which FF will otherwise refuse to install. Requires no setup and has no options, but simply disables this check.

I would have given a full five stars without hesitation, if not for a few minor issues:

* In the add-on list, it is titled "checkCompatibility," which is badly formatted and confusing because it's the opposite of what the add-on actually does. Something more like the title on this page ("Disable Add-on Compatibility Checks") would be much more appropriate.

* Description is confusing, mentioning the variable name many times while only indirectly stating the primary function of disabling the check, and what this will allow in practice.

* If disabled or removed, the add-ons it facilitated will also be disabled at the next restart. This should be mentioned somewhere in the description or upon disabling, since one might reasonably assume this add-on is no longer needed after the compatibility is confirmed during installation.


I consider this add-on to provide critical functionality which should be included in FF itself, especially considering the frequency of its revision releases and the fact that most newer addons will still function perfectly. Until mozilla allows us to perform "experimental" installations again, this add-on works beautifully. Thanks so much!

Great Rated 5 out of 5 stars

Very good ! Nothing to add thanks you.

I needed this! Rated 5 out of 5 stars

Firefox changes all the time. It's no surprise that Add-on developers can't always keep up, especially casual developers who develop great add-ons in their spare time. For times when a developer hasn't had a chance to flag their add-on as compatible with the latest version of Firefox, this Add-on is invaluable to prevent those add-ons from being disabled! Thanks!

Works great on FF 22 Rated 5 out of 5 stars

Does exactly what it should on FF22! Thanks!

Rated 1 out of 5 stars

the addon does absolutely nothing // FF21
rating - 0

Rated 5 out of 5 stars

Works with Aurora(Nightly) 24.0a1, Win x64

Rated 5 out of 5 stars

It works for FF21

no disable here Rated 1 out of 5 stars

i am running ff21 and this does absolutely nothing and is worthless here

Rated 5 out of 5 stars

Thanks for this addon, now i can use Firefox 2 theme reloaded for FF20.0.1.

At last I have no need to go to 'about:config' after every update Rated 5 out of 5 stars

At last I have no need to go to 'about:config' after every update.
Thank you.

Superb Rated 5 out of 5 stars

Thanks for this suberb add-on.
It makes my favorite Classic Compact theme working in FF20

Rated 4 out of 5 stars

Awesome but incomplete. In order for me to get my extension to work I needed to turn off this extension as well: extensions.checkUpdateSecurity. Otherwise 5 stars.

Rated 5 out of 5 stars

THANK YOU!! This made my favorite FT Evo Theme compatible with Firefox 19 again!! Highly recomended and 5 *

Saved my Googel Toolbar! Rated 5 out of 5 stars

Just moved from 17.xx to 18.xx and my Google Toolbar still remains functional. The best Add-On I have. Thank You!!

Rated 5 out of 5 stars

great

doesn't work with complete reinstalls of FF Rated 1 out of 5 stars

Maybe this checkCompatibility 1.3 add-on works with automatic internal updates of FF(?), but not with complete reinstalls...

I had it enabled in FF 18.0, uninstalled FF while keeping my personal data and settings, then installed FF 18.0.1 from "Firefox Setup 18.0.1.exe" (19,821 KB). That's my usual procedure. I don't trust the automatic internal updates which often cause problems in my experience.

My add-ons were checked for compatibility and one of them was disabled, so it didn't work (had no effect). That limitation should be made clear in the description.

Thanks for an essential fix! Rated 5 out of 5 stars

I still can't believe the Thunderbird devs think it's okay to blow up essential extensions WITHOUT EVEN ASKING. Especially since the upgrades are super-sneaky. I open my Thunderbird one day, and the calendar is gone -- poof! -- and the subject headings are back to the usual useless people send. (Stuff like "stuff," so I'd have to open every email to find out what's in it.)

Getting into about:config and setting compatibility to off for each picayune little version number gets real old, too.

Without this extension, the devs make Thunderbird just about worse than useless.

Rated 5 out of 5 stars

Thanks to this LIGHTWEIGHT addon @3.1 KB

I'm able to keep using "Screen Capture Elite" addon in FF 13 & above.

Works great Rated 5 out of 5 stars

Great extension, it lets me keep using extensions and themes that have not been updated. This has become one of my must have Firefox extensions!!

Rated 5 out of 5 stars

Fantastic, finally some much needed extensions are working again!