Thunderbird 24 compatibility Rated 3 out of 5 stars

Does the compatibility need updating? It shows as "Works with Thunderbird 2.0a1 - 15.0a1" and I'm blocked from installing this on Thunderbird 24.

This review is for a previous version of the add-on (1.19.1).